Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Voir le sujet précédent Voir le sujet suivant Aller en bas

Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Philomèle le Sam 1 Fév 2014 - 13:47

Bonjour à tous,

Je cherche une solution (qui doit exister !) à un problème de prof qui bénit l'existence d'Excel au moment du calcul des moyennes.

Je dois calculer la moyenne d'environ 120 étudiants à une UE complexe. Les étudiants ont cinq notes au cours du semestre, trois en T.D. et deux en C.M., chacune avec un coefficient différent. J'ai donc saisi ces notes dans un "tableau dynamique" Excel et j'applique une formule de calcul à chaque ligne du tableau pour automatiser le calcul de la moyenne de l'UE.

Mon problème concerne le cas d'étudiants qui n'ont pas fait un ou plusieurs travaux. Il manque à ces étudiants une note (ou plusieurs), mais ils ont tout de même quelques notes par ailleurs. Dans ce cas, je dois signaler l'absence et cette absence doit bloquer le calcul de la moyenne, même s'ils ont d'autres notes. Or même si j'indique une mention du type "Abs" dans la cellule où aurait dû figurer une note, la formule de calcul s'applique malgré tout et un chiffre de résultat s'affiche pour la moyenne de l'UE. Cela ne va pas, je voudrais que le calcul soit bloqué, pour signaler l'absence, d'une façon ou d'une autre.

Savez-vous ce que je devrais indiquer dans la cellule de la note manquante ou quel paramètre je devrais appliquer à cette cellule pour que le calcul s'interrompe ?

Pour l'instant, je bricole en indiquant (à la place d'"Absent") le graphème "#DIV/0!", qui a l'avantage de provoquer l'apparition de "#DIV/0!" dans la colonne "moyenne de l'UE". Mais je ne sais pas vraiment ce que signifie ce "#DIV/0!". Il y a sans doute une solution plus maîtrisée.

La documentation excel est illisible : je ne sais pas comment s'appelle ce que je cherche, je ne trouve pas de solution à mon problème en épluchant les résultats donnés par Google.

Quelqu'un aurait-il compris mon problème et aurait-il une solution ? Merci d'avance.

Philomèle
Niveau 9


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Dedale le Sam 1 Fév 2014 - 14:24

Ce n'est pas dit que ce soit la solution la plus simple/efficace, mais quelque-chose comme cela doit fonctionner.
Code:
=SI(NB.SI(A1:C1;"Abs")>=1;"Abs";MOYENNE(A1:C1))
Cette formule regarde si le terme "Abs" est présent au moins une fois dans l'une des 3 cellules de A1 à C1. Si tel est le cas, elle renvoit également le terme "Abs", sinon elle affiche la valeur de la moyenne.
Est-ce bien cela que tu veux faire?

Dedale
Niveau 9


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Philomèle le Sam 1 Fév 2014 - 14:52

Merci beaucoup d'avoir pris du temps pour te pencher sur le problème.

Oui, c'est exactement cela que je veux faire.
J'ai tenté de saisir la formule inspirée de la tienne (correspondant aux cellules de mon tableau) dans la barre de calcul pour la moyenne du TD : =SI(NB.SI(F3:H3;"Abs")>=1;"Abs";AVERAGE(F3;G3;H3;H3)) (les notes des cellules F3 et G3 sont coef.1 et la note de la cellule H3 est coef. 2)

J'édite le présent message : ça marche ! Merci beaucoup !

D'où question suivante : cela marche sur la ligne qui m'a servi de support de test. Est-ce que tu saurais comment modifier la formule de calcul de l'ensemble des lignes du tableau ? Je tire le "carré noir" pour l'ensemble de la colonne de résultats : ça marche pour les étudiants Abs., par contre chaque cellule de la colonne comportant une moyenne calculée (car pas d'absence) porte  l'indication d'une erreur avec le coin vert (erreur que je n'identifie pas, sinon ce serait trop facile).

Philomèle
Niveau 9


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Zenxya le Sam 1 Fév 2014 - 15:56

Il faut peut-être que tu utilises les $ :
=SI(NB.SI($F3:$H3;......etc

Zenxya
Sage


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Philomèle le Sam 1 Fév 2014 - 16:04

@Zenxya a écrit:Il faut peut-être que tu utilises les $ :
=SI(NB.SI($F3:$H3;......etc

Merci beaucoup ! ça marche !

Et question subsidiaire, si je peux abuser : est-il possible de créer une formule qui prenne en considération les cellules vides ?
J'ai une série d'étudiants qui n'a pas de notes du tout. Dans ce cas, comme les cellules sont vides, l'application de la fonction ci-dessous redonne #DIV/0!
Que faudrait-il faire pour obtenir dans la colonne moyenne la mention "Abs." ? Merci d'avance.

Philomèle
Niveau 9


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Zenxya le Sam 1 Fév 2014 - 16:48

Il faut rajouter un ET pour tester les cellules
=SI(ET($F3="",$G3="";$H3="")=VRAI;"Abs";SI(NB.SI($F3:H3;....etc

Zenxya
Sage


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Philomèle le Sam 1 Fév 2014 - 18:17

@Zenxya a écrit:Il faut rajouter un ET pour tester les cellules
=SI(ET($F3="",$G3="";$H3="")=VRAI;"Abs";SI(NB.SI($F3:H3;....etc

Merci beaucoup ! ça marche :
=SI(ET($F3="";$G3="";$H3="")=VRAI;"Déf.";SI(NB.SI($F3:H3;"Déf.")>=1;"Déf.";MOYENNE($F3;$G3;$H3;$H3)))

(Lorsque la formule rencontre des cellules vides, j'obtiens bien l'affichage de la mention "Abs", ce qui est l'essentiel, mais avec le coin vert qui indique une erreur. Je n'arrive pas à comprendre ce qui cloche encore, et cela m'agace de ne pas comprendre, mais je crois que je vais en rester là pour aujourd'hui.)

Philomèle
Niveau 9


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Zenxya le Sam 1 Fév 2014 - 19:11

Excel indique parfois une "erreur" quand les autres formules des cellules adjacentes ne sont pas du même style.

Zenxya
Sage


Revenir en haut Aller en bas

Re: Question aux pros d'Excel : empêcher l'application d'une formule de calcul

Message par Philomèle le Sam 1 Fév 2014 - 19:33

@Zenxya a écrit:Excel indique parfois une "erreur" quand les autres formules des cellules adjacentes ne sont pas du même style.

Merci pour l'hypothèse (qui me tranquillise). Il y a des chances pour que ce soit ça.
Bonne soirée.

Philomèle
Niveau 9


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum