Partagez
Voir le sujet précédentAller en basVoir le sujet suivant
Mamino
Mamino
Habitué du forum

Condition et date dans excel Empty Condition et date dans excel

par Mamino Lun 6 Juin 2011 - 9:43
Dans la colonne A1, figure une date de naissance.
Dans la colonne B1, je voudrais la réponse "oui" si la date de naissance est postérieure au 1/9/85 et "non" si elle est antérieure.
J'ai utilisé la formule suivante :

=SI(A1>1/9/1985;"oui";"non")

Les résultats sont folkloriques ...
Où est l'erreur ???
avatar
Atea
Niveau 3

Condition et date dans excel Empty Re: Condition et date dans excel

par Atea Lun 6 Juin 2011 - 10:03
Il faut utiliser la fonction "date"

=SI(A1>DATE(1985;9;1);"oui";"non")

Sinon excel effectue le calcul 1/9/1985 et compare avec la date (qui en fait est le nombre de jours depuis le 01/01/1900)
Mamino
Mamino
Habitué du forum

Condition et date dans excel Empty Re: Condition et date dans excel

par Mamino Lun 6 Juin 2011 - 10:32
@Atea a écrit:Il faut utiliser la fonction "date"

=SI(A1>DATE(1985;9;1);"oui";"non")

Sinon excel effectue le calcul 1/9/1985 et compare avec la date (qui en fait est le nombre de jours depuis le 01/01/1900)

Merci, merci ! ça marche !

Je venais de tricher avec quelques dollars de plus en utilisant la formule:
=SI(A1>$A$18;"oui";"non")
et en mettant dans la case A18 la date de référence ... et ça marchait. C'était du bricolage !
Voir le sujet précédentRevenir en hautVoir le sujet suivant
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum